hitode909の日記

趣味はマリンスポーツですの日記です

名前

昨日読んだコード、$nameっていう変数の先頭二文字を取り出した変数名が$naでおもしろかった。おもしろいけどうれしさはない。
先頭二文字取り出す必要があるなら、何かシステム的に意味のある行為のはずで、システム的に意味のある名前がなかったら何か名前をつけて、みんなその名前で呼んだり話したりできるようにする必要があると思う。たとえば、「名前の先頭二文字」より、「ユーザーのプロフィールアイコンの格納されているディレクトリ」のほうがわかりやすい。ディレクトリは、仕様としては、名前の先頭二文字を使う、とか。
また、あちこちで名前の先頭二文字を気にしてるのは変で、プロフィールアイコンクラスにこの人のURL作ってくださいってお願いしたらURLもらえるほうが普段は先頭二文字とか無視できて便利。

blameしてないから特定の人をdisってるわけではなくて、こういうコードは一般的にこうあるべきという話で、blameしてないから僕が書いたのかもしれない。