hitode909の日記

趣味はマリンスポーツですの日記です

jQuery 1.9から $.browserがなくなって, modernizrを使えって書いてあった.modernizrを使うと,IE7かどうか,とかじゃなくて,audioタグがoggをサポートしているか,とかで調べることになる.既存のコードで,なぜかIE7では動かないからコメントアウト,とかしてるところがあって,それはなんでIE7で動かないか知らないから,結局,IE7かどうか自分で判定するコードを自分で書くことになった.ということがあった.